What’s Vulnerable › Vulnerabilities
CVE-2026-81153: Robo Gallery < 5.2.6 - Author+ Stored XSS via Image Overlay Effect Meta
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-11 · updated 2026-10-13
- Weakness: CWE-79
Description
The Robo Gallery WordPress plugin before 5.2.6 does not sanitise and escape some of its image settings before outputting them in a gallery page, allowing users with the Author role and above to perform Stored Cross-Site Scripting attacks that execute in the browser of any visitor viewing the gallery, including administrators, even where the unfiltered_html capability is disallowed such as on multisite.
Affected products
- Robo Gallery: before 5.2.6 — fixed in 5.2.6
How to fix
Upgrade to a fixed version: Robo Gallery 5.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-81153 or the next vulnerability affects your stack