What’s Vulnerable › Vulnerabilities
CVE-2026-81340: MasterStudy LMS < 3.7.50 - Instructor+ Order Status Manipulation via IDOR
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-18
- Weakness: CWE-639
Description
The MasterStudy LMS WordPress Plugin WordPress plugin before 3.7.50 does not perform per-object ownership or capability checks when updating orders through its REST API, allowing users with the Instructor role to modify any order on the site, granting free course enrolment, revoking other users' paid enrolments, and tampering with order notes.
Affected products
- MasterStudy LMS WordPress Plugin: before 3.7.50 — fixed in 3.7.50
How to fix
Upgrade to a fixed version: MasterStudy LMS WordPress Plugin 3.7.50. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-81340 or the next vulnerability affects your stack