What’s Vulnerable › Vulnerabilities
CVE-2026-81428: WC Vendors < 2.7.2.1 - Vendor+ Cross-Vendor Product and Arbitrary Post Modification via IDOR
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-03
- Weakness: CWE-639
Description
The WC Vendors WordPress plugin before 2.7.2.1 does not verify ownership or the object type of user-supplied IDs when saving product variations, allowing authenticated users with the vendor role to modify product variations belonging to other vendors, and to change the status and title of arbitrary posts, via IDOR.
Affected products
- WC Vendors: before 2.7.2.1 — fixed in 2.7.2.1
How to fix
Upgrade to a fixed version: WC Vendors 2.7.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-81428 or the next vulnerability affects your stack