What’s Vulnerable › Vulnerabilities
CVE-2026-81525: Cross-tenant database retargeting via dot/NUL injection in namespace strings in the PHP Driver
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-29
- Weakness: CWE-943
Description
The MongoDB client library for PHP does not sufficiently sanitize special elements in application-supplied namespace identifiers before using them to construct the target namespace for database operations. An application that incorporates untrusted text into these identifiers may have operations silently directed at a different storage location than the one the application intended.
Affected products
- MongoDB PHP Driver: before 1.21.6; from 2.0.0 before 2.4.1 — fixed in 1.21.6, 2.4.1
- MongoDB PHP Library: before 1.21.4; from 2.0.0 before 2.4.1 — fixed in 1.21.4, 2.4.1
How to fix
Upgrade to a fixed version: MongoDB PHP Driver 1.21.6, 2.4.1; MongoDB PHP Library 1.21.4, 2.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/mongodb/mongo-php-driver/releases/tag/1.21.6
- https://github.com/mongodb/mongo-php-driver/releases/tag/2.4.1
- https://github.com/mongodb/mongo-php-library/releases/tag/1.21.4
- https://github.com/mongodb/mongo-php-library/releases/tag/2.4.1
- https://jira.mongodb.org/browse/PHPLIB-1927
Get alerted when CVE-2026-81525 or the next vulnerability affects your stack