What’s Vulnerable › Vulnerabilities
CVE-2026-8155: BuddyPress < 14.5.0 - Subscriber+ Private Messages Disclosure via IDOR
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-31 · updated 2026-08-26
- Weakness: CWE-639
Description
The BuddyPress WordPress plugin before 14.5.0 does not properly enforce authorization on its private messaging endpoints, allowing any authenticated user (Subscriber+) to read, modify, or delete other users' private messages.
Affected products
- BuddyPress: before 14.5.0 — fixed in 14.5.0
How to fix
Upgrade to a fixed version: BuddyPress 14.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8155 or the next vulnerability affects your stack