What’s Vulnerable › Vulnerabilities
CVE-2026-81576: Improper Authentication of Session Handles
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-01
- Weakness: CWE-639
Description
If configured as a server, CodeMeter Runtime before versions 8.41a and 9.10 issues handles per connection and relies on a cryptographically weak SID as sole authenticator. An attacker can brute-force the SID, recover another session's handle number, and read license information belonging to another handle.
Affected products
- wibu-systems-ag codemeter-runtime: from 9.00 before 9.10; from 8.00 before 8.41a; 7.00, 6.00 — fixed in 8.41a, 9.10
How to fix
Upgrade to a fixed version: wibu-systems-ag codemeter-runtime 8.41a, 9.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-81576 or the next vulnerability affects your stack