What’s Vulnerable › Vulnerabilities
CVE-2026-81655: Ad Inserter 2.8.12 - 2.8.18 - Subscriber+ RCE / Stored XSS via Global Custom Fields
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-27 · updated 2026-09-28
- Weakness: CWE-94
Description
The Ad Inserter WordPress plugin before 2.8.19 does not correctly restrict access to one of its settings pages, making it reachable by every logged in user under a configuration its own settings allow, and does not filter the content saved there, allowing users with a role as low as subscriber to store code which is then executed as PHP or served unescaped to site visitors.
Affected products
- Ad Inserter: from 2.8.12 before 2.8.19 — fixed in 2.8.19
How to fix
Upgrade to a fixed version: Ad Inserter 2.8.19. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-81655 or the next vulnerability affects your stack