What’s Vulnerable › Vulnerabilities
CVE-2026-81679: OpenRemote before 1.28.0 Cross-Realm Information Disclosure via Notification API
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-10-08
- Weakness: CWE-200
Description
OpenRemote versions before 1.28.0 contain a cross-realm information disclosure vulnerability in the Notification REST API that allows per-realm tenant administrators to read all tenants' sent notifications including message bodies. Attackers with read:admin credentials in one realm can submit a zero-parameter GET request to the notification endpoint to retrieve sensitive notification metadata and message content from all realms.
Affected products
- openremote: before 1.28.0 — fixed in 1.28.0
How to fix
Upgrade to a fixed version: openremote 1.28.0. Check the vendor advisory for mitigations.
References
- https://github.com/openremote/openremote/security/advisories/GHSA-6ff4-4frc-r287
- https://www.vulncheck.com/advisories/openremote-before-1.28.0-cross-realm-information-disclosure-via-notification-api
Get alerted when CVE-2026-81679 or the next vulnerability affects your stack