What’s Vulnerable › Vulnerabilities
CVE-2026-8168: Denial-of-service vulnerability in the SVG parser and renderer impacts Qt
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-19
- Weakness: CWE-674
Description
Uncontrolled recursion in the SVG parser and renderer of the Qt SVG module (QtSvg) in Qt Group Qt allows attackers to cause a denial of service (application crash via stack exhaustion) via a crafted SVG file with deeply nested elements.
Affected products
- Qt: from 4.1.0 before 6.8.9; from 6.9.0 before 6.11.2 — fixed in 6.11.2, 6.8.9
How to fix
Upgrade to a fixed version: Qt 6.11.2, 6.8.9. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtsvg/+/730501
- https://codereview.qt-project.org/c/qt/qtsvg/+/730590
- https://codereview.qt-project.org/c/qt/qtsvg/+/730591
- https://codereview.qt-project.org/c/qt/qtsvg/+/730892
- https://codereview.qt-project.org/c/qt/qtsvg/+/731257
- https://codereview.qt-project.org/c/qt/qtsvg/+/733245
- https://codereview.qt-project.org/c/qt/qtsvg/+/738811
- https://codereview.qt-project.org/c/qt/qtsvg/+/743488
- https://codereview.qt-project.org/c/qt/qtsvg/+/748966
- https://codereview.qt-project.org/c/qt/qtsvg/+/756512
- https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-8168:
Get alerted when CVE-2026-8168 or the next vulnerability affects your stack