What’s Vulnerable › Vulnerabilities
CVE-2026-81682: openssl_encrypt before 1.4.9 Insecure File Permissions
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-23
- Weakness: CWE-276
Description
openssl_encrypt versions before 1.4.9 contain an insecure file permissions vulnerability in the desktop GUI that writes decrypted plaintext with world-readable default permissions. Attackers can read decrypted output files created by the GUI as unprivileged local users on multi-user systems.
Affected products
- jahlives openssl_encrypt: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-7q4g-rrw4-rf2m
- https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-insecure-file-permissions
Get alerted when CVE-2026-81682 or the next vulnerability affects your stack