What’s Vulnerable › Vulnerabilities
CVE-2026-81684: openssl_encrypt before 1.4.9 Information Disclosure via Command Line
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-03
- Weakness: CWE-214
Description
In openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8, the desktop GUI passes the steganography password to the CLI child process on the command line via the --stego-password argument (on both encrypt and decrypt paths) instead of via an environment variable as done for the main password. Any local user can read the steganography password from /proc/<pid>/cmdline for the lifetime of the subprocess. Fixed in 1.4.9.
Affected products
- jahlives openssl_encrypt: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-rx2c-m92f-qv6p
- https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-information-disclosure-via-command-line
Get alerted when CVE-2026-81684 or the next vulnerability affects your stack