What’s Vulnerable › Vulnerabilities
CVE-2026-81718: openssl_encrypt before 1.4.9 Weak Cryptographic Parameters
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-23
- Weakness: CWE-326
Description
openssl_encrypt versions before 1.4.9 use under-parameterized PBKDF2-HMAC-SHA256 with only 100,000 iterations to protect PQC keyfile private keys and 10,000 iterations for dual-encryption file-password verification. Attackers who obtain keyfiles or encrypted files can brute-force wrapping passwords offline using GPU or ASIC acceleration.
Affected products
- jahlives openssl_encrypt: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-fmjx-p826-6fvr
- https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-weak-cryptographic-parameters
Get alerted when CVE-2026-81718 or the next vulnerability affects your stack