What’s Vulnerable › Vulnerabilities
CVE-2026-81719: openssl_encrypt before 1.4.9 Remote Code Execution via Plugin
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-02
- Weakness: CWE-94
Description
openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.
Affected products
- jahlives openssl_encrypt: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: jahlives openssl_encrypt 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-587j-4r3v-cm2c
- https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-remote-code-execution-via-plugin
Get alerted when CVE-2026-81719 or the next vulnerability affects your stack