What’s Vulnerable › Vulnerabilities
CVE-2026-81727: NLTK before 3.10.3 Hardlink File Overwrite via downloader
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-27 · updated 2026-08-31
- Weakness: CWE-59
Description
NLTK versions before 3.10.3 contain a filesystem containment bypass vulnerability in the Downloader.download and Downloader.incr_download methods that allows attackers to overwrite files outside the install root through pre-existing hardlinks. Attackers with write access to a shared downloader directory can create hardlinks pointing to outside-root files that are then overwritten during normal package extraction, mutating files outside the intended install tree.
Affected products
- nltk: before 3.10.3 — fixed in 3.10.3
How to fix
Upgrade to a fixed version: nltk 3.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/nltk/nltk/security/advisories/GHSA-f794-5jv7-7672
- https://www.vulncheck.com/advisories/nltk-before-3.10.3-hardlink-file-overwrite-via-downloader
- https://github.com/nltk/nltk/security/advisories/GHSA-f794-5jv7-7672
Get alerted when CVE-2026-81727 or the next vulnerability affects your stack