What’s Vulnerable › Vulnerabilities
CVE-2026-81739: Paytm Payment Gateway < 2.8.9 - Unauthenticated Stored XSS via Payment Callback
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-01
- Weakness: CWE-79
Description
The Paytm Payment Gateway WordPress plugin before 2.8.9 does not sanitize and escape data it stores from payment callbacks before outputting it in an admin page, and the integrity check on those callbacks can be forged when the gateway is enabled without credentials, allowing unauthenticated users to store scripts that will run in the session of a store administrator.
Affected products
- Paytm Payment Gateway: before 2.8.9 — fixed in 2.8.9
How to fix
Upgrade to a fixed version: Paytm Payment Gateway 2.8.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-81739 or the next vulnerability affects your stack