What’s Vulnerable › Vulnerabilities
CVE-2026-8183: Langflow OSS is affected by arbitrary code execution in custom component validation and trusted code enforcement
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-10-24
- Weakness: CWE-22
Description
IBM Langflow OSS 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, 1.0.0 through 1.10.3, and 1.0.0 through 1.10.3 could allow a remote attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot " sequences ( /.. /) to v i ew arbitrary files on the system.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8183 or the next vulnerability affects your stack