What’s Vulnerable › Vulnerabilities

CVE-2026-81940: Langflow is vulnerable to arbitrary code execution due to multiple incomplete code security controls and missing execution guards

Description

IBM Langflow OSS 1.0.0 through 1.11.5 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of special characters in flow display names.

Affected products

How to fix

Upgrade to a fixed version: IBM Langflow OSS 1.11.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-81940 or the next vulnerability affects your stack