What’s Vulnerable › Vulnerabilities
CVE-2026-8201: Use-After-Free in MongoDB FLE Query Analysis When Processing Positional Projections on Encrypted Fields
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-416
Description
A use-after-free vulnerability exists in MongoDB's Field-Level Encryption (FLE) query analysis component, affecting client-side uses of mongocryptd and crypt_shared. Triggering this vulnerability requires control over the structure of a client's FLE-related query. This issue impacts MongoDB Server’s mongocryptd component v7.0 versions prior to 7.0.34, v8.0 versions prior to 8.0.23, v8.2 versions prior to 8.2.9 and v8.3 versions prior to 8.3.2.
Affected products
- MongoDB: from 7.0.0 before 7.0.34; from 8.0.0 before 8.0.23; from 8.2.0 before 8.2.9; from 8.3.0 before 8.3.2 — fixed in 7.0.34, 8.0.23, 8.2.9, 8.3.2
How to fix
Upgrade to a fixed version: MongoDB 7.0.34, 8.0.23, 8.2.9, 8.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8201 or the next vulnerability affects your stack