What’s Vulnerable › Vulnerabilities
CVE-2026-82024: LearnPress WordPress Plugin < 4.4.6 Stored XSS via Quiz Question Answer Titles
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-08
- Weakness: CWE-79
Description
LearnPress WordPress Plugin before 4.4.6 contains a stored cross-site scripting vulnerability that allows authenticated attackers with the Instructor role to inject persistent malicious payloads by submitting unsanitized input into quiz question answer title fields. Attackers can store arbitrary JavaScript through the answer title parameter, which is rendered through an unescaped HTML sink to execute in the browsers of any user who views the affected quiz question, including students, other instructors, and administrators.
Affected products
- thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses: before 4.4.6 — fixed in 4.4.6
How to fix
Upgrade to a fixed version: thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses 4.4.6. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/learnpress/#developers
- https://www.vulncheck.com/advisories/learnpress-wordpress-plugin-stored-xss-via-quiz-question-answer-titles
Get alerted when CVE-2026-82024 or the next vulnerability affects your stack