What’s Vulnerable › Vulnerabilities
CVE-2026-82065: Insufficient Validation of Storage Configuration Options in MongoDB Server Leads to Persistent Denial of Service via Corrupted Metadata
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-16
- Weakness: CWE-617
Description
A security issue in the MongoDB Server's storage engine integration layer allows an authenticated user with collection creation privileges to cause a persistent denial of service. Insufficient validation of user-supplied storage configuration options permits values that, once persisted to durable metadata, trigger a fatal assertion failure when the metadata is subsequently read by diagnostic operations. The corrupted metadata persists across server restarts and is replicated to other cluster members, requiring manual operator intervention to restore service.
Affected products
- MongoDB: from 7.0.0 before 7.0.41; from 8.0.0 before 8.0.30; from 8.3.0 before 8.3.9 — fixed in 7.0.41, 8.0.30, 8.3.9
How to fix
Upgrade to a fixed version: MongoDB 7.0.41, 8.0.30, 8.3.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82065 or the next vulnerability affects your stack