What’s Vulnerable › Vulnerabilities
CVE-2026-82070: Insufficiently Protected Credentials in MongoDB Server Diagnostic Reporting Interface
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-16
- Weakness: CWE-522
Description
A security issue in MongoDB Server's diagnostic reporting interface allows an authenticated user with monitoring privileges to access insufficiently protected credentials from concurrent administrative operations. The same credentials are properly redacted in server log output, but the diagnostic interface omits equivalent redaction. Successful exploitation requires a valid authenticated session with monitoring-level permissions and results in exposure of cleartext credentials that could enable impersonation of other users, including privileged accounts.
Affected products
- MongoDB: from 7.0.0 before 7.0.40; from 8.0.0 before 8.0.29; from 8.2.0 through 8.2.12; from 8.3.0 before 8.3.8; 9.0.0-alpha0, 9.0.0-alpha1, 9.1.0-alpha0 — fixed in 7.0.40, 8.0.29, 8.3.8
How to fix
Upgrade to a fixed version: MongoDB 7.0.40, 8.0.29, 8.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82070 or the next vulnerability affects your stack