What’s Vulnerable › Vulnerabilities
CVE-2026-82071: Insufficient Validation of Storage Engine Configuration Options in MongoDB Server Leads to Out-of-Bounds Write
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-16
- Weakness: CWE-787
Description
Insufficient validation of storage engine configuration options in MongoDB Server allows an authenticated user with write privileges to supply crafted parameters during collection creation that override internal storage metadata. This results in an out-of-bounds memory write in the server process, causing a denial of service via server crash, with potential for further impact including arbitrary code execution.
Affected products
- MongoDB: from 8.3.0 before 8.3.9 — fixed in 8.3.9
How to fix
Upgrade to a fixed version: MongoDB 8.3.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82071 or the next vulnerability affects your stack