What’s Vulnerable › Vulnerabilities
CVE-2026-82074: Incorrect Authorization in MongoDB Server Aggregation Framework Allows Unauthorized Read Access to Collection Data
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-16
- Weakness: CWE-863
Description
MongoDB Server contains an incorrect authorization vulnerability in the aggregation framework. An authenticated user with minimal privileges can craft a specially formatted aggregation request that causes the server's authorization subsystem to evaluate a different operation than what is actually executed, resulting in unauthorized read access to collection data within the target database.
Affected products
- MongoDB: from 7.0.0 before 7.0.41; from 8.0.0 before 8.0.30 — fixed in 7.0.41, 8.0.30
How to fix
Upgrade to a fixed version: MongoDB 7.0.41, 8.0.30. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82074 or the next vulnerability affects your stack