What’s Vulnerable › Vulnerabilities
CVE-2026-8212: OSGeo gdal SWapi.c SWSDfldsrch heap-based overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-09 · updated 2026-07-24
- Weakness: CWE-119
Description
A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch is called 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.
Affected products
- OSGeo gdal: through 3.12.4; 3.13.0-beta1, 3.13.0-beta2
References
- https://github.com/OSGeo/gdal/
- https://github.com/OSGeo/gdal/commit/3e04c0385630e4d42517046d9a4967dfccfeb7fd
- https://github.com/OSGeo/gdal/issues/14398
- https://github.com/OSGeo/gdal/releases/tag/v3.13.0RC1
- https://github.com/biniamf/pocs/tree/main/gdal-swsdfldsrch_oob-read
- https://vuldb.com/submit/808127
- https://vuldb.com/vuln/362429
- https://vuldb.com/vuln/362429/cti
Get alerted when CVE-2026-8212 or the next vulnerability affects your stack