What’s Vulnerable › Vulnerabilities
CVE-2026-82239: Budibase before 3.41.3 Authorization Bypass via datasources/query
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-10-08
- Weakness: CWE-862
Description
Budibase before 3.41.3 fails to enforce per-table role restrictions on the POST /api/datasources/query endpoint, allowing low-privilege BASIC users to read, create, update, or delete rows in any table regardless of configured permissions. Attackers with BASIC role can submit crafted query requests with target table identifiers to bypass table-level access controls and manipulate restricted data.
Affected products
- budibase server: before 3.41.3 — fixed in 3.41.3
How to fix
Upgrade to a fixed version: budibase server 3.41.3. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-vq3j-xwg3-pg8x
- https://www.vulncheck.com/advisories/budibase-before-3.41.3-authorization-bypass-via-datasources-query
- https://github.com/Budibase/budibase/security/advisories/GHSA-vq3j-xwg3-pg8x
Get alerted when CVE-2026-82239 or the next vulnerability affects your stack