What’s Vulnerable › Vulnerabilities
CVE-2026-82240: Budibase before 3.41.3 Privilege Escalation via User Update API
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-10-08
- Weakness: CWE-862
Description
Budibase before 3.41.3 fails to validate app-scoped builder role assignments in the public user create and update endpoints, allowing an authenticated app-scoped builder to grant builder access to unrelated apps. Attackers can submit crafted requests to the user update API with builder.apps fields to escalate privileges and gain unauthorized builder access to other applications in the same tenant.
Affected products
- budibase server: before 3.41.3 — fixed in 3.41.3
How to fix
Upgrade to a fixed version: budibase server 3.41.3. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-468g-55qj-v8rr
- https://www.vulncheck.com/advisories/budibase-before-3.41.3-privilege-escalation-via-user-update-api
Get alerted when CVE-2026-82240 or the next vulnerability affects your stack