What’s Vulnerable › Vulnerabilities
CVE-2026-82242: Budibase before 3.41.3 Cross-Application Resource Injection via Missing Authorization
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-10-08
- Weakness: CWE-862
Description
Budibase versions before 3.41.3 contain a missing authorization vulnerability in the POST /api/resources/duplicate endpoint that allows authenticated builders to inject tables, automations, queries, and screens into any other application without holding any role in the destination workspace. Attackers can inject resources by specifying an arbitrary destination workspace ID in the request body, then trigger injected automations with outgoing webhooks to exfiltrate data from victim applications.
Affected products
- budibase server: before 3.41.3 — fixed in 3.41.3
How to fix
Upgrade to a fixed version: budibase server 3.41.3. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-xqpq-288m-r5q7
- https://www.vulncheck.com/advisories/budibase-before-3.41.3-cross-application-resource-injection-via-missing-authorization
- https://github.com/Budibase/budibase/security/advisories/GHSA-xqpq-288m-r5q7
Get alerted when CVE-2026-82242 or the next vulnerability affects your stack