What’s Vulnerable › Vulnerabilities
CVE-2026-82243: Budibase Server before 3.41.3 SSRF with Credential Leakage
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-10-08
- Weakness: CWE-918
Description
Budibase Server before 3.41.3 contains a server-side request forgery vulnerability in the datasource verify endpoint that allows builder-level users to supply arbitrary URLs without SSRF validation. Attackers can exploit this to leak internal CouchDB credentials by making requests to attacker-controlled servers, gaining full database access in cloud deployments.
Affected products
- budibase server: before 3.41.3 — fixed in 3.41.3
How to fix
Upgrade to a fixed version: budibase server 3.41.3. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-83m5-fvmg-r7xv
- https://www.vulncheck.com/advisories/budibase-server-before-3.41.3-ssrf-with-credential-leakage
- https://github.com/Budibase/budibase/security/advisories/GHSA-83m5-fvmg-r7xv
Get alerted when CVE-2026-82243 or the next vulnerability affects your stack