What’s Vulnerable › Vulnerabilities
CVE-2026-82244: Budibase before 3.41.3 Remote Code Execution via Plugin eval()
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-10-08
- Weakness: CWE-94
Description
Budibase versions before 3.41.3 contain a remote code execution vulnerability in plugin handling that allows authenticated admin users to execute arbitrary code by uploading a malicious plugin tarball. The server calls eval() on plugin JavaScript files without sandboxing in the main Node.js process, enabling attackers to exfiltrate environment variables and credentials with root privileges in default deployments.
Affected products
- budibase server: before 3.41.3 — fixed in 3.41.3
How to fix
Upgrade to a fixed version: budibase server 3.41.3. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-gwr2-pgg3-p7xp
- https://www.vulncheck.com/advisories/budibase-before-3.41.3-remote-code-execution-via-plugin-eval
Get alerted when CVE-2026-82244 or the next vulnerability affects your stack