What’s Vulnerable › Vulnerabilities
CVE-2026-82246: Budibase Server before 3.41.3 SSRF via Query Import
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-10-08
- Weakness: CWE-918
Description
Budibase Server before 3.41.3 contains a server-side request forgery vulnerability in the query import endpoint that fails to validate user-supplied URLs before fetching content. Attackers can submit arbitrary URLs to retrieve responses from internal services including cloud metadata endpoints and other restricted network resources.
Affected products
- budibase server: before 3.41.3 — fixed in 3.41.3
How to fix
Upgrade to a fixed version: budibase server 3.41.3. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-48x3-9ph2-p9gj
- https://www.vulncheck.com/advisories/budibase-server-before-3.41.3-ssrf-via-query-import
- https://github.com/Budibase/budibase/security/advisories/GHSA-48x3-9ph2-p9gj
Get alerted when CVE-2026-82246 or the next vulnerability affects your stack