What’s Vulnerable › Vulnerabilities
CVE-2026-82333: multer vulnerable to Denial of Service via oversized array index in field names
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-02
- Weakness: CWE-400
Description
multer is a middleware for handling multipart/form-data in Node.js. A small multipart request with two specially crafted text field names can make multer's field parser synchronously iterate a maximum-length sparse array, blocking the event loop so the process cannot handle other requests. A large numeric array index in the first field allocates a maximum-length sparse array, and a second field with a non-numeric key then triggers a full-length iteration inside the append-field dependency. All versions before 2.3.0 are affected, and this is a remotely triggerable denial of service. multer 2.3.0 adds an opt-in fieldArrayIndexLimit option that rejects oversized array indexes. Upgrade to multer 2.3.0 and set limits.fieldArrayIndexLimit to the largest array index your application needs to remediate.
Affected products
- multer: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: multer 2.3.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/multer/security/advisories/GHSA-535w-7cp7-47q4
Get alerted when CVE-2026-82333 or the next vulnerability affects your stack