What’s Vulnerable › Vulnerabilities
CVE-2026-82410: Pocketbase: Unhandled panic in worker goroutines
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-30
- Weakness: CWE-248
Description
Pocketbase is an open source web backend written in go. Prior to 0.22.48 and 0.39.7, PocketBase's panic-recovery middleware covers regular request handling but not internal child and worker goroutines. A panic in one of these internal goroutines can escape recovery and terminate the server process, causing a denial of service. The remediation introduces routine.SafeWrap to convert recovered panics into regular errors and applies it to the affected internal worker functions. This issue is fixed in versions 0.22.48 and 0.39.7.
Affected products
- pocketbase: before 0.22.48; from 0.23.0, < 0.39.7
References
- https://github.com/pocketbase/pocketbase/commit/30b4184305904fae0d1b78216c4e3cc34700b220
- https://github.com/pocketbase/pocketbase/commit/f1618ee59b6d1c0308bb474c827a2b1f24b12a95
- https://github.com/pocketbase/pocketbase/discussions/7762
- https://github.com/pocketbase/pocketbase/releases/tag/v0.22.48
- https://github.com/pocketbase/pocketbase/releases/tag/v0.39.7
- https://github.com/pocketbase/pocketbase/security/advisories/GHSA-84vh-m24q-wjjx
Get alerted when CVE-2026-82410 or the next vulnerability affects your stack