What’s Vulnerable › Vulnerabilities
CVE-2026-82460: Cloud Commander before 19.20.2 Directory Traversal via REST and Markdown
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-29 · updated 2026-09-24
- Weakness: CWE-22
Description
Cloud Commander before 19.20.2 contains a directory traversal vulnerability in REST file-operation and markdown endpoints that fails to properly validate path normalization. Attackers can use path traversal sequences to read, write, move, or copy files outside the configured root directory.
Affected products
- coderaiser cloudcmd: before 19.20.2 — fixed in 19.20.2
How to fix
Upgrade to a fixed version: coderaiser cloudcmd 19.20.2. Check the vendor advisory for mitigations.
References
- https://github.com/coderaiser/cloudcmd
- https://github.com/coderaiser/cloudcmd/blob/v19.20.1/server/root.js
- https://github.com/coderaiser/cloudcmd/commit/b9bdc9ed528350eeb2f9ef974c18998096fae919
- https://github.com/coderaiser/cloudcmd/issues/474
- https://github.com/coderaiser/cloudcmd/releases/tag/v19.20.2
- https://www.vulncheck.com/advisories/cloud-commander-before-19.20.2-directory-traversal-via-rest-and-markdown
- https://github.com/coderaiser/cloudcmd/issues/474
Get alerted when CVE-2026-82460 or the next vulnerability affects your stack