What’s Vulnerable › Vulnerabilities
CVE-2026-82519: Really Simple Security < 9.8.2 Authorization Bypass via profile-page update handler
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-20
- Weakness: CWE-862
Description
Really Simple Security plugin for WordPress before 9.8.2 contains a missing authorization check vulnerability that allows authenticated low-privileged attackers to bypass enforced two-factor authentication indefinitely by exploiting an unguarded code path in the profile-page update handler. Attackers can submit a crafted POST request without the two-factor-authentication field to skip nonce verification and trigger delete_two_fa_meta(), which resets the grace period anchor timestamp on every login cycle, causing mandatory 2FA enforcement to be deferred indefinitely.
Affected products
- reallysimpleplugins Really Simple Security: before 9.8.2 — fixed in 9.8.2
How to fix
Upgrade to a fixed version: reallysimpleplugins Really Simple Security 9.8.2. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/really-simple-ssl/#developers
- https://www.vulncheck.com/advisories/really-simple-security-authorization-bypass-via-profile-page-update-handler
Get alerted when CVE-2026-82519 or the next vulnerability affects your stack