What’s Vulnerable › Vulnerabilities
CVE-2026-82531: Smarty before 4.5.8 and 5.x before 5.8.5 PHP Code Injection via extends: Inheritance Cache
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-06
- Weakness: CWE-94
Description
Smarty before 4.5.8 and 5.x before 5.8.5 contains a code injection vulnerability where the top-level nocache_hash is never restored during extends:/multi-component template inheritance, leaving it null. Attackers can supply assigned data containing a forged SmartyNocache marker that is copied verbatim into the regenerated PHP cache file, executing arbitrary PHP on include for remote code execution.
Affected products
- smarty-php smarty: before 4.5.8; from 5.0.0 before 5.8.5 — fixed in 4.5.8, 5.8.5
How to fix
Upgrade to a fixed version: smarty-php smarty 4.5.8, 5.8.5. Check the vendor advisory for mitigations.
References
- https://github.com/smarty-php/smarty/commit/1cba51cb813563eb61d963c83d28cd59f26b858d
- https://github.com/smarty-php/smarty/commit/c0fdd4824aca4f67e814b50703cfee1dfde41414
- https://github.com/smarty-php/smarty/releases/tag/v4.5.8
- https://github.com/smarty-php/smarty/releases/tag/v5.8.5
- https://github.com/smarty-php/smarty/security/advisories/GHSA-3w63-v7pm-cq9x
- https://www.vulncheck.com/advisories/smarty-before-4.5.8-and-5-x-before-5.8.5-php-code-injection-via-extends-inheritance-cache
- https://github.com/smarty-php/smarty/security/advisories/GHSA-3w63-v7pm-cq9x
Get alerted when CVE-2026-82531 or the next vulnerability affects your stack