What’s Vulnerable › Vulnerabilities

CVE-2026-82632: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.9 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user with a fine-grained Personal Access Token scoped only to user-boundary import permissions to import projects into group namespaces beyond the token's intended scope, due to incorrect authorization of the import target namespace.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.2.8, 19.3.5, 19.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-82632 or the next vulnerability affects your stack