What’s Vulnerable › Vulnerabilities
CVE-2026-82710: Terminal escape sequence injection in mix usage_rules.search_docs via package documentation metadata
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-08
- Weakness: CWE-150
Description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in ash-project usage_rules allows a malicious package publisher to inject terminal control sequences into the output of mix usage_rules.search_docs. mix usage_rules.search_docs searches Hex documentation through search.hexdocs.pm, which indexes the documentation of every published package, and prints the matching results (title, package, type, doc reference, and highlighted snippets) to the terminal. The formatter in Mix.Tasks.UsageRules.SearchDocs interpolated those publisher-controlled fields verbatim, neutralizing no terminal control characters; the only transform it applied adds escape sequences rather than removing them. A malicious package can embed ANSI terminal escape sequences (cursor movement, line erase, carriage returns, OSC 52 clipboard writes) in its indexed documentation, so when a developer runs a search that surfaces those docs the sequences reach the terminal unchanged — forging the displayed hexdocs URL or a suggested command, hiding text, or writing to the clipboard. No authentication or privileged position is required; only publishing a package. This issue affects usage_rules: from 0.1.18 before 1.2.8.
Affected products
- ash-project usage_rules: from 0.1.18 before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: ash-project usage_rules 1.2.8. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-82710.html
- https://github.com/ash-project/usage_rules/commit/3b8ebb4117d3272bbd436e6c2432113ba6685dbb
- https://github.com/ash-project/usage_rules/security/advisories/GHSA-j59f-776f-23hp
- https://osv.dev/vulnerability/EEF-CVE-2026-82710
Get alerted when CVE-2026-82710 or the next vulnerability affects your stack