What’s Vulnerable › Vulnerabilities
CVE-2026-82727: AshPhoenix Form.Auto leaks submitted params in an unknown _union_type error message
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-31 · updated 2026-09-01
- Weakness: CWE-209
Description
Generation of Error Message Containing Sensitive Information vulnerability in ash-project ash_phoenix writes the entire raw submitted param map into an exception message, so secrets submitted alongside a union form field leak into logs, crash reports and the dev error page. When AshPhoenix.Form.Auto builds a union sub-form and the submitted _union_type does not match a configured type, both raise sites built the message with inspect(params, pretty: true), embedding the full untrusted param map, and also inspected the internal union constraints[:types]. Because the message is constructed by the library rather than Phoenix's parameter logger, config :phoenix, :filter_parameters never redacts it. An attacker controls both the trigger and the contents: submitting %{"_union_type" => "nope", "password" => "..."} puts the password verbatim in the raised message. The fix reports only the offending _union_type and the valid type names, dropping the param and constraints dumps. This issue affects ash_phoenix: from 1.2.17 before 2.3.25.
Affected products
- ash-project ash_phoenix: from 1.2.17 before 2.3.25 — fixed in 2.3.25
How to fix
Upgrade to a fixed version: ash-project ash_phoenix 2.3.25. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-82727.html
- https://github.com/ash-project/ash_phoenix/commit/0c1775c3cf8988f9abd10a8f92315afc5f06f16d
- https://github.com/ash-project/ash_phoenix/security/advisories/GHSA-5xf4-hgcq-xw7v
- https://osv.dev/vulnerability/EEF-CVE-2026-82727
- https://github.com/ash-project/ash_phoenix/security/advisories/GHSA-5xf4-hgcq-xw7v
Get alerted when CVE-2026-82727 or the next vulnerability affects your stack