What’s Vulnerable › Vulnerabilities
CVE-2026-82804: Apache DolphinScheduler: Command Injection in the Alert Script Plugin
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-09-29
- Weakness: CWE-78
Description
The scriptPath parameter is incorporated into a /bin/sh -c command without sufficient neutralization of shell metacharacters, allowing shell command substitution and execution. An authenticated user can exploit this behavior by creating a resource whose filename contains shell command substitution syntax, such as $(...), and subsequently supplying the resulting path to the Alert Script plugin's /test-send endpoint. When the alert script is executed, the shell interprets the injected command, resulting in arbitrary command execution with the privileges of the DolphinScheduler service process. This issue affects Apache DolphinScheduler: before 3.4.3. Users are recommended to upgrade to version 3.4.3, which fixes the issue.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.4.3 — fixed in 3.4.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.4.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/mwzbs5qdhs7nblfz70jgs0z54qx3phql
- http://www.openwall.com/lists/oss-security/2026/09/29/25
Get alerted when CVE-2026-82804 or the next vulnerability affects your stack