What’s Vulnerable › Vulnerabilities

CVE-2026-82837: Insertion of Sensitive Information Into Sent Data in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.1.0 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that certain conditions could have allowed an authenticated user to access sensitive credentials and tokens without transiting the expected proxy due to improper authorization checks on internal data emission endpoints.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.1.8, 19.2.6, 19.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-82837 or the next vulnerability affects your stack