What’s Vulnerable › Vulnerabilities
CVE-2026-82843: WP OAuth Server < 6.4.0 - Subscriber+ Cross-User Account Takeover via OIDC ID Token Substitution
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-24
- Weakness: CWE-287
Description
The WP OAuth Server ( Login with WordPress ) WordPress plugin before 6.4.0 does not bind the OpenID Connect identity assertion it issues to the authorization grant being exchanged, returning instead the assertion belonging to whichever user authenticated most recently, which allows users with the Subscriber role and above to obtain a validly signed identity assertion for another user, including an administrator, and authenticate as them at any application that uses the site for single sign-on.
Affected products
- WP OAuth Server ( Login with WordPress ): before 6.4.0 — fixed in 6.4.0
How to fix
Upgrade to a fixed version: WP OAuth Server ( Login with WordPress ) 6.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82843 or the next vulnerability affects your stack