What’s Vulnerable › Vulnerabilities
CVE-2026-82845: Masteriyo LMS < 3.4.1 - Subscriber+ PHP Object Injection
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-12 · updated 2026-09-14
- Weakness: CWE-502
Description
The Masteriyo LMS WordPress plugin before 3.4.1 does not prevent user-supplied values held as metadata from being deserialized when they are read back, allowing users with a minimal account to inject arbitrary PHP objects and, by way of a class shipped in a library bundled with the Masteriyo LMS WordPress plugin before 3.4.1, write and execute arbitrary code on the server. A weaker form of the same issue is reachable without an account and yields an arbitrary file write rather than code execution.
Affected products
- Masteriyo LMS: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Masteriyo LMS 3.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82845 or the next vulnerability affects your stack