What’s Vulnerable › Vulnerabilities

CVE-2026-82846: Masteriyo LMS 1.18.0 - 2.3.3 - Instructor+ Stored XSS via Course Custom Fields

Description

The Masteriyo LMS WordPress plugin before 3.4.0 does not sanitise and escape some course settings before outputting them in a page available to all visitors, allowing users with a course-author role to perform Stored Cross-Site Scripting attacks that run in the session of anyone viewing the course, including a logged-in administrator.

Affected products

How to fix

Upgrade to a fixed version: Masteriyo LMS 3.4.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-82846 or the next vulnerability affects your stack