What’s Vulnerable › Vulnerabilities
CVE-2026-82847: Masteriyo LMS < 3.4.1 - Instructor+ Stored XSS via Course Highlights
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-12 · updated 2026-09-14
- Weakness: CWE-79
Description
The Masteriyo LMS WordPress plugin before 3.4.1 does not sanitise and escape one of its course fields before outputting it back in the course editor, allowing users with the instructor role to perform Stored Cross-Site Scripting attacks against higher privileged users such as administrators.
Affected products
- Masteriyo LMS: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Masteriyo LMS 3.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82847 or the next vulnerability affects your stack