What’s Vulnerable › Vulnerabilities
CVE-2026-82848: Masteriyo LMS 1.3.1 - 2.3.3 - Unauthenticated Course Enrollment Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-09-09
- Weakness: CWE-862
Description
The Masteriyo LMS WordPress plugin before 3.4.0 does not perform any authorization check before returning a course enrolment record over its REST API, allowing unauthenticated users to read any learner's enrolment status, timestamps and course-progress data by walking sequential record identifiers. A related gap lets any enrolled user retrieve other learners' enrolment records as well.
Affected products
- Masteriyo LMS: from 1.3.1 before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: Masteriyo LMS 3.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82848 or the next vulnerability affects your stack