What’s Vulnerable › Vulnerabilities
CVE-2026-82851: Masteriyo LMS 1.14.0 - 3.4.0 - Instructor+ Arbitrary Post Disclosure via IDOR
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-12 · updated 2026-09-14
- Weakness: CWE-639
Description
The Masteriyo LMS WordPress plugin before 3.4.1 does not verify ownership of, or restrict the type of, the records a user requests for download, allowing users with the instructor role to retrieve the full content and metadata of arbitrary posts, including other instructors' private and draft courses.
Affected products
- Masteriyo LMS: from 1.14.0 before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Masteriyo LMS 3.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-82851 or the next vulnerability affects your stack