What’s Vulnerable › Vulnerabilities
CVE-2026-82856: @hulumi/policies before 1.3.2 OIDC Trust Policy Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-31 · updated 2026-10-08
- Weakness: CWE-284
Description
@hulumi/policies versions before 1.3.2 fail to properly validate set-qualified AWS IAM condition operators in GitHub OIDC trust policies. Attackers can use ForAnyValue:StringLike operators to hide wildcard GitHub Actions OIDC subject conditions from security guardrails.
Affected products
- hulumi policies: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: hulumi policies 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-q2f7-m237-v562
- https://www.vulncheck.com/advisories/hulumi-policies-before-1.3.2-oidc-trust-policy-bypass
Get alerted when CVE-2026-82856 or the next vulnerability affects your stack