What’s Vulnerable › Vulnerabilities
CVE-2026-82857: hulumi before v1.3.2 Privilege Escalation via IAM Policy
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-31 · updated 2026-09-01
- Weakness: CWE-269
Description
hulumi versions before v1.3.2 contain a privilege escalation vulnerability in the weekly integration IAM policy that allows role lifecycle operations on af-e2e-* roles without sufficient boundary restrictions. Attackers with the documented principal can create persistent higher-privilege roles in the sandbox account.
Affected products
- kerberosmansour hulumi: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: kerberosmansour hulumi 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-35qr-vx94-m5x3
- https://www.vulncheck.com/advisories/hulumi-before-1.3.2-privilege-escalation-via-iam-policy
Get alerted when CVE-2026-82857 or the next vulnerability affects your stack