What’s Vulnerable › Vulnerabilities
CVE-2026-82858: @hulumi/drift before 1.3.2 Unsafe Execute Plan Acceptance
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-31 · updated 2026-10-08
- Weakness: CWE-345
Description
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
Affected products
- hulumi drift: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: hulumi drift 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-2ffm-hxrq-qqmm
- https://www.vulncheck.com/advisories/hulumi-drift-before-1.3.2-unsafe-execute-plan-acceptance
Get alerted when CVE-2026-82858 or the next vulnerability affects your stack