What’s Vulnerable › Vulnerabilities
CVE-2026-82864: pdfme pdf-lib before 5.5.10 Denial of Service via Decompression Bomb
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-31 · updated 2026-10-08
- Weakness: CWE-409
Description
pdfme pdf-lib versions before 5.5.10 contain an unbounded buffer growth vulnerability in the DecodeStream.ensureBuffer() method that allows attackers to cause denial of service by supplying a crafted PDF with a FlateDecode stream containing a decompression bomb. Attackers can upload a small compressed PDF that decompresses to hundreds of megabytes, exhausting memory and crashing the Node.js process or freezing browser tabs during PDF parsing.
Affected products
- pdfme pdf-lib: before 5.5.10 — fixed in 5.5.10
How to fix
Upgrade to a fixed version: pdfme pdf-lib 5.5.10. Check the vendor advisory for mitigations.
References
- https://github.com/pdfme/pdfme/security/advisories/GHSA-vrqm-gvq7-rrwh
- https://www.vulncheck.com/advisories/pdfme-pdf-lib-before-5.5.10-denial-of-service-via-decompression-bomb
Get alerted when CVE-2026-82864 or the next vulnerability affects your stack